A partial archive of meta.discourse.org as of Tuesday July 18, 2017.

Checklist Plugin - Interactive Checkboxes made Simple


I'm happy to announce that I've ported the checklist plugin created by @lightyear to run on the latest version of Discourse.

You can find the new repo at https://github.com/cpradio/discourse-plugin-checklist

With this release comes a few enhancements.

  • You can disable the plugin in its entirety from the Admin > Settings area (strike through still gets processed, but the checkboxes won't render and won't be clickable)
  • You can keep checking/unchecking boxes on the same post without having to refresh the page.

Any issues should be reported either here or via a GitHub issue. I also welcome translation file PRs, or general enhancement PRs.


Whoever uses the plugin, please tell us about your ideas of its application in your forum.


Thanks for this, it's really useful for teams that use discourse to track bugs, features or plans.


This is fun, but before installing it, my team is trying to figure out what's the difference here between using the plugin and just using emoji, e.g.:

  • :ballot_box_with_check: Something I finished

  • :black_square_button: Something I haven't finished

Anyone have feedback?


Much better the plugin, for the simple reason you do not have to re-open the post and add an icon but simply click on the task you complete!
Using icons is a nightmare if you have a lot of to-do list to control (believe me!) :smiley:


The difference is that the plugin lets you interact with the checkboxes in the posts, creating a quick todo list style ability. So when you complete a task, you simply click the checkbox to check it.

Feel free to play with it at https://sandbox.cpradio.org


How do I uninstall this plugin?


Per the README on github

Follow the directions at Install a Plugin using https://github.com/cpradio/discourse-plugin-checklist.git as the repository URL.


Thanks for the quick follow up. My app.yml file looks like this (no github clone lines anywhere):


Page down, it is near the bottom of the app.yml


Ah, I see, thank you.


Hello, I'm seeing errors on my log that seems to be thrown by your plugin.

The error is Uncaught TypeError: Cannot read property 'getModel' of undefined, and seems to be thrown here:

It happens whenever an user opens a markdown editor, or types something in it.


What version of Discourse and of the Checklist Plugin are you running?


Discourse v1.6.0.beta1 +48

discourse-plugin-checklist 0.2.0


K, just released a fix for that.


That fixed it, thanks for the quick reply!


Thanks @cpradio I have installed this plugin on my site and work very well :slight_smile:


For some reason, it won't let Discrouse bootstrap:


Pups::ExecError: cd /var/www/discourse/plugins && git clone https://github.com/cpradio/discourse-plugin-checklist.git failed with return #
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home/plugins", "cmd"=>["mkdir -p plugins", "git clone https://github.com/discourse/docker_manager.git", "git clone https://github.com/discourse/discourse-data-explorer.git", "git clone https://github.com/discourse/discourse-staff-notes.git", "git clone https://github.com/angusmcleod/discourse-quick-messages.git", "git clone https://github.com/joebuhlig/discourse-feature-voting.git", "git clone https://github.com/cpradio/discourse-plugin-checklist.git", "git clone https://github.com/angusmcleod/discourse-ratings.git", "git clone https://github.com/angusmcleod/discourse-topic-previews.git", "git clone https://github.com/cpradio/discourse-plugin-checklist.git"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

As soon as I comment out the git clone instruction for this plugin, Discourse bootstraps normally again.


If you go to a random folder on your server and run git clone https://github.com/cpradio/discourse-plugin-checklist.git does it work? (maybe in /home/yourusername)

Also how much physical memory do you have and what is your swap? My server still seems to run okay.


git clone worked just fine in a /tmp folder while on root account.
Running a 2GB-memory instance at DigitalOcean with a 1GB swap configured.