A partial archive of meta.discourse.org as of Tuesday July 18, 2017.

IE11 in compatibility mode (intranet) is getting “your browser is too old”


Hi all,

having implemented the workaround mentioned here, Discourse is showing the “your browser is too old” message again since upgrade to v1.9+.

I’ve checked that /etc/nginx/conf.d/discourse.conf still contains the workaround and it dies but still have no success in getting the forum displayed in an IE11 with compatibility mode enabled (intranet).

Unfortunately, disabling compatibility mode for intranet pages centrally is not an option (altough it would fix this specific issue).

Do you have any advise/idea?

Thanks a lot in advance and Cheers


You can continue this here, but you’ll need to whitelist Discourse, or otherwise send the required IE11 header.